The ThinManual
The Abridged Guide to ThinManager

Version 4.0
Revision 3

December 3, 2010 ©
Automation Control Products
www.thinmanager.com
Atlanta, Georgia, USA
# Table of Contents

1. **Setup Overview** ................................................................. 4  
2. **Microsoft Terminal Services** ............................................... 5  
   2.1. Role of Terminal Server .................................................. 5  
   2.2. 2003 Terminal Server Configuration ................................. 5  
   2.3. 2008 Terminal Server Setup .......................................... 5  
   2.4. Microsoft Licensing ....................................................... 6  
   2.5. Microsoft Users ............................................................ 7  
   2.6. Terminal Services Configuration ..................................... 7  
   2.7. Microsoft Commands ..................................................... 9  
   2.8. Alternative Terminal Keystrokes .................................... 10  
3. **Network** ........................................................................... 10  
4. **The Thin Client Boot Process** ............................................ 11  
5. **ThinManager** ................................................................. 11  
   5.1. Role of ThinManager ....................................................... 11  
   5.2. ThinManager Installation ............................................... 11  
   5.3. Redundant ThinManagers .............................................. 12  
6. **ThinManager Licensing** .................................................... 14  
   6.1. Master Licenses ............................................................. 14  
   6.2. License Types .............................................................. 16  
   6.3. Enterprise Licenses ....................................................... 16  
   6.4. Standard Licenses ........................................................ 17  
7. **Hardware Configuration** .................................................. 18  
   7.1. IP Addressing .............................................................. 18  
8. **ThinManager Configuration** .............................................. 19  
   8.1. Terminal Configuration .................................................. 19  
   8.2. Display Servers ............................................................ 20  
   8.3. Display Client Configuration ......................................... 21  
9. **MultiSession** ................................................................. 23  
   9.1. Configuring the Terminal for MultiSession ....................... 23  
   9.2. Switching Between Sessions ......................................... 24  
10. **SmartSession** ............................................................. 24  
    10.1. Configuring the Terminal Server Display Server .............. 24  
    10.2. Configuring the SmartSession Display Client .................. 25  
11. **Modules** ........................................................................ 25
11.1. Updating Modules ................................................................. 26
12. WinTMC ............................................................................... 26
  12.1. WinTMC Advantages ...................................................... 26
  12.2. WinTMC Disadvantages ............................................... 26
  12.3. WinTMC Installation ....................................................... 27
  12.4. WinTMC Configuration on the Client .............................. 27
  12.5. WinTMC Configuration in ThinManager ....................... 27
13. Shadowing ........................................................................... 27
  13.1. ThinManager Shadowing ............................................... 28
  13.2. Terminal Shadow Display Client .................................... 28
14. Additional Topics ................................................................. 28
  14.1. MultiMonitor ................................................................. 28
  14.2. Reports ........................................................................... 29
  14.3. Touch Screens ............................................................. 30
  14.4. Event Log ....................................................................... 30
  14.5. Security .......................................................................... 30
  14.6. Scheduling ..................................................................... 31
  14.7. SessionTiling ................................................................. 31
15. Failover and Instant Failover .................................................. 31
  15.1. Definitions ..................................................................... 31
  15.2. Failover Configuration ................................................... 32
  15.3. Instant Failover Configuration........................................ 32
16. ThinManager Troubleshooting Guide ...................................... 34
  16.1. From Power on to Terminal Server Login ....................... 34
  16.2. Thin Client is Running a Session on the Terminal Server ... 37
1. **Setup Overview**

(All you need to know about ThinManager in 100* words or less)

**Microsoft**

- Build a terminal server with the Microsoft Windows 2003 or 2008 Server operating system. Enable Terminal Services. See Section 2.2.
- Create a Microsoft Licensing Server and add a TS CAL (Terminal Server Client Access License) for each thin client. They also require a normal CAL. See Section 2.4.
- Create a Microsoft user profile for each terminal on the terminal server. Make sure that the user is a member of the Remote Desktop Users Windows group. See Section 2.5.
- Apply appropriate security to each user profile using the standard Microsoft techniques.

**ThinManager**

- Install ACP ThinManager software onto a computer to create a ThinManager Server. See Section 5.2.
- Create a Master ACP License and add enough Product Licenses for each ThinManager Ready thin client. See Section 6.1.

**Hardware**

- Establish the IP addressing scheme for the thin clients, Static IP or DHCP. See Section 7.1.
- If using DHCP, configure Option 066 to list the IP address of the ThinManager Server. See Section 7.1.1.
- Attach the terminals to ThinManager by either:
  - Turning on the terminal and selecting the "Create New Terminal" option when the offline terminals are listed.
  - Pre-creating the terminals in ThinManager and selecting the proper terminal name when the terminal is turned on and offline terminals are listed.

**Results**

- Step 1: The clients will connect to the ThinManager Server and download the firmware and configuration.
- Step 2: The configuration will send them to the terminal server to login and start a session.

* Closer to 250
2. **Microsoft Terminal Services**

Microsoft has changed terminology for Server 2008.

This document will maintain the Windows 2003 versions of the terms. These include TSCALs (Terminal Services Client Access License) instead of RDS CAL (Remote Desktop Services Client Access License) and Terminal Services instead of Remote Desktop Services or Session Hosting.

### 2.1. Role of Terminal Server

A terminal server is a Windows 2003 or 2008 server that has terminal services enabled. This configures the server to use a mainframe-style client/server architecture. A client logs into the terminal server and starts a session. Keystrokes and mouse movements are sent from the client to the session on the terminal server. All processing takes place on the terminal server and the resulting graphics are sent to the client for display.

The ThinManager configuration sends the ThinManager Ready thin client to the terminal server(s) to start a session(s).

### 2.2. 2003 Terminal Server Configuration

ThinManager Ready thin clients rely on Microsoft terminal servers.

- Build a Windows 2003 Server. A clean install is better than converting an existing server.
- Enable Terminal Services in the Windows Components Wizard by selecting `Start > Control Panel > Add/Remove Programs > Add/Remove Windows Components` and checking the `Terminal Services` checkbox.
- Select the `Permission Compatibility` during the Terminal Services installation. Most HMIs require the default `Relaxed Security` because the `Full Security` setting requires users to have administrative rights. This can be changed in the `Server Settings` of the `Terminal Services Configuration Console` (Section 2.6.2).

### 2.3. 2008 Terminal Server Setup

- Build a Windows 2008 Server. A fresh install is preferred.
- Add the Terminal Server role.
- Install the desired applications using the `Install Application on Terminal Server` program found in the Control Panel.
- Create the users on the terminal server and add them to the `Remote Desktop Users` group.
- Go to the `TS RemoteApp Manager` and either allow unlisted applications or add permission the applications you want to run.
2.3.1. Virtual Memory

- Set the Virtual Memory page file to 2.5 times the size of the physical memory to increase performance.
- Go to Control Panel > System > the Advanced tab > Performance Settings to launch the Performance Options.
- Select the Virtual Memory Change button on the Advanced tab.
- Set the Initial size and Maximum size to the same value to speed performance.
- Changing the virtual memory requires a computer reboot.

2.4. Microsoft Licensing

Each terminal or user will require a CAL (Client Access License) and TSCAL (Terminal Services Client Access License) or RDS CAL (Remote Desktop Services Client Access License in 2008) to access the terminal servers. The TSCALs are not pooled but allow connection to an unlimited number of terminal servers.

- Add a Terminal Services Licensing Server (TSLS) to the network by checking the Terminal Server Licensing checkbox on the Windows Components page. (Start> Control Panel> Add/Remove Programs> Add/Remove Windows Components). This is not a separate piece of hardware but an application to install and run on an existing server.
- Microsoft normally recommends a single TSLS per network. They recommend that it be installed on the Domain Controller, if available. Windows 2003 SP1 and later have a License Server setting in the Server Settings of the Terminal Services Configuration Console that allows multiple TSLSs. See Server Settings in section 2.6.2 for details.
- Activate the TSLS by selecting Start>Programs>Administrative Tools>Terminal Server Licensing on the Terminal Server Licensing Server and selecting Action>Activate Server from the menu to launch the licensing wizard. Follow Microsoft’s instructions.
- Activate the TSCALs on the TSLS through the licensing wizard following Microsoft’s instructions.

Terminals will connect without a TSLS and receive a 120-day temporary TSCAL. When this expires the terminal will display an “Unable to connect to terminal server” error message in the top left corner of its monitor. The cause of the error, lack of a TSLS and TSCALs, can be found in the terminal server event log where it will show a “Client license is unable to be issued” error message. Add TSCALs to an activated TSLS to solve this issue.
2.5. Microsoft Users

Terminals require a valid Windows user account to start a session on the terminal servers. These can be domain accounts or local accounts on each terminal server.

- Create a unique user account for each terminal or user in the Computer Management console (Start> Program Files> Administrative Tools> Computer Management). Highlight the Users folder in System Tools/Local Users and Groups and select Action> New User from the menu.

- Add the users to either the Remote Desktop Users group or the Administrators group to allow access to the terminal server.

- Apply any group policies as needed.

- Windows 2003 activates a secure screen saver for each user by default requiring CTL+ALT+DEL to unlock. Users of touch screens will want to deactivate this, either in each user account or in the Group Policy Editor (gpedit.msc) at User Configuration>Administrative Templates>Control Panel>Display.

2.6. Terminal Services Configuration

The Terminal Services Configuration console provides tools for configuring the connection between terminals and the terminal server. It is launched from Administrative Tools.

These are a few of note:

2.6.1. Connections – RDP-tcp Properties

- Open the Terminal Services Configuration (Start> Program Files> Administrative Tools> Terminal Services Configuration), highlight Connections on the left and double-click on RDP-tcp on the right to launch the RDP-tcp Properties page.

  **Allow Audio Mapping for Terminal Sound**

  - Sound redirection to terminals is turned off by default.

  - Select the Client Settings tab and unselect Audio Mapping to allow sound to be redirected to the terminal.

  - Any users will need to log out and login to apply the change.

**End Disconnected Sessions**

Most users will want to keep disconnected sessions on the server to allow a user to reconnect to an existing session.

Disconnected sessions can be deleted from the terminal server to reduce the resource and to have terminals start fresh sessions when they reconnect.

- Select the Sessions tab, select the Override user settings and set the End a disconnected session parameter.

- Any users will need to log out and login to apply the change.
2.6.2. Server Settings

- Open the Terminal Services Configuration (Start > Program Files > Administrative Tools > Terminal Services Configuration), highlight Server Settings on the left.

Licensing
Microsoft TSCALs are available as Per Device and Per User. The setting in Licensing should match the style installed on the License Server.

Permission Compatibility
During installation of Terminal Servers you have an option of using Full Security or Relaxed Security for applications on the server.

Most HMIs require Relaxed Security because the Full Security setting requires users to have administrative rights.

This setting allows the permissions to be changed.

License Server Discovery
Microsoft recommends a single Terminal Services License Server (TSLS) on a network. Having multiple TSLSs can cause the terminals connection problems. If multiple TSLSs are used the terminal server can have its TSLS specified to ease licensing issues.

- Double-click on License server discovery mode on the right.
- Select the Use these license servers radio button and enter the name of the license server.
### 2.7. Microsoft Commands

Terminal Services has several commands that aid in managing the terminal server. Some useful ones are:

<table>
<thead>
<tr>
<th>Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>change logon</td>
<td>Temporarily disables logons to a Terminal Server</td>
</tr>
<tr>
<td>change port</td>
<td>Changes COM port mappings for MS-DOS program compatibility</td>
</tr>
<tr>
<td>change user /install</td>
<td>Puts the server into &quot;Install Mode&quot;</td>
</tr>
<tr>
<td>change user /execute</td>
<td>Removes the server from &quot;Install Mode&quot;</td>
</tr>
<tr>
<td>ipconfig</td>
<td>Displays the IP addresses of the network card</td>
</tr>
<tr>
<td>logoff</td>
<td>Logs off a user from a session and deletes the session from the server</td>
</tr>
<tr>
<td>net send username “message”</td>
<td>Sends a message to a user. <strong>username</strong> is the NT/2000 user name that the person or terminal is logged in as. “<strong>message</strong>” is the text of the message. Quotation marks are needed for any messages containing a space.</td>
</tr>
<tr>
<td>query process</td>
<td>Displays information about processes running on a Terminal server</td>
</tr>
<tr>
<td>query session</td>
<td>Displays information about sessions on a Terminal server</td>
</tr>
<tr>
<td>query termserverserver</td>
<td>Displays a list of all Terminal servers on the network</td>
</tr>
<tr>
<td>query user</td>
<td>Displays information about user sessions on a Terminal server</td>
</tr>
<tr>
<td>reset session</td>
<td>Resets a session to known initial values</td>
</tr>
<tr>
<td>shadow</td>
<td>Monitors another user's session</td>
</tr>
<tr>
<td>tsdiscon</td>
<td>Disconnects a client from a terminal server session</td>
</tr>
<tr>
<td>tsshutdn</td>
<td>Shuts down the terminal server in an orderly manner</td>
</tr>
</tbody>
</table>

Commands to launch useful Microsoft programs include:

<table>
<thead>
<tr>
<th>Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>gedit.msc</td>
<td>Launches the Group Policy Editor</td>
</tr>
<tr>
<td>secpol.msc</td>
<td>Launches the Local Security Policy</td>
</tr>
<tr>
<td>tsc.msc</td>
<td>Launches the Terminal Services Configuration Console</td>
</tr>
<tr>
<td>tsadmin</td>
<td>Launches the Terminal Services Manager</td>
</tr>
</tbody>
</table>
2.8. **Alternative Terminal Keystrokes**

Certain keystrokes are not available in a terminal session. Microsoft has provided these alternatives.

<table>
<thead>
<tr>
<th>Keystroke</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALT+PAGE UP</td>
<td>Switches between programs from left to right.</td>
</tr>
<tr>
<td>ALT+PAGE DOWN</td>
<td>Switches between programs from right to left.</td>
</tr>
<tr>
<td>ALT+INSERT</td>
<td>Cycles through the programs in the order they were started.</td>
</tr>
<tr>
<td>ALT+HOME</td>
<td>Displays the Start menu.</td>
</tr>
<tr>
<td>CTRL+ALT+BREAK</td>
<td>Switches the client between a window and full screen.</td>
</tr>
<tr>
<td>CTRL+ALT+END</td>
<td>Brings up the Windows 2000 Security dialog box.</td>
</tr>
<tr>
<td>ALT+DELETE</td>
<td>Displays the Windows menu.</td>
</tr>
<tr>
<td>CTRL+ALT+Minus (-) symbol on the numeric keypad</td>
<td>Places a snapshot of the active window, within the client, on the Terminal server clipboard (provides the same functionality as pressing PrintScrn on a local computer.)</td>
</tr>
<tr>
<td>CTRL+ALT+Plus (+) symbol on the numeric keypad</td>
<td>Places a snapshot of the entire client window area on the Terminal server clipboard (provides the same functionality as pressing ALT+PrintScrn on a local computer.)</td>
</tr>
</tbody>
</table>

3. **Network**

Thin clients and terminal servers need a reliable network.

Make sure that the following network ports are unblocked:

- UDP/4900 - TFTP - Used for the TFTP download of the firmware.
- TCP/2031 - Configuration - Used to pass the configuration from the ThinManager Server to the thin client.
- TCP/1494 - Citrix - Used by the ICA protocol (if using ICA instead of RDP).
- TCP/3389 - RDP - Used by the RDP protocol (if using RDP in v2.4.1 or later).
- TCP/5900 - Shadowing - Used to shadow terminals. This can be changed on the **Shadow Configuration** page of the **ThinManager Server Configuration Wizard**.
- TCP/1758 – Used if the default Multicast is used.
  - If the network MTU size is not the default then the packet size needs changed on the Multicast Configuration page of the ThinManager Server Configuration Wizard.
- ICMP Echo Packets (Ping) – Used by WinTMC and Enforce Primary.
- DHCP - This need configured as needed.
4. The Thin Client Boot Process

- The terminal is turned on and connects to the network.
- The terminal receives an IP address either through the default DHCP or by being configured with static IP.
- The terminal connects to a ThinManager Server (defined in Option 066 of DHCP or by static IP) and downloads its configuration.
- This configuration sends the terminal to the terminal server(s).

5. ThinManager

5.1. Role of ThinManager

- ThinManager allows the configuration of ThinManager Ready thin clients.
- A ThinManager Ready thin client needs to connect to a ThinManager Server and receive its configuration.
- This configuration sends the ThinManager Ready thin client to a terminal server(s) to start a session and run.
- ThinManager allows an administrator to monitor and manage the thin client system.
- ThinManager provides security to the thin client system.

5.2. ThinManager Installation

- Install on a server or a workstation.
- It is not required to be on the terminal server although that is a common practice.
- Installation through Add/Remove Programs is required for a terminal server installation and is recommended on other computers.
- ThinManager gives three checkboxes for installation. Normally all three are selected.
  - ThinServer is the engine that runs the program.
  - ThinManager is the interface that allows control and configuration of the ThinServer engine.
  - ThinManager Tools are additional tools like touch screen calibration.

5.2.1. ThinManager Server Setup in 2008

- Install ThinManager using the Install Application on Terminal Server program found in the Control Panel.
- Go to the firewall and allow all inbound communications or open ports in the firewall to allow UDP port 4900 and TCP port 2031 traffic.
You may need to go to the *Local Security Policy* and change the *User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode* to *Elevate without prompting*.

### 5.2.2. ThinManager versus ThinServer

- The ThinManager program is composed of two parts, a ThinServer engine and a ThinManager interface.
- ThinServer is the engine that does the work. It supplies the firmware, controls SmartSession, and holds the licenses and configuration.
- ThinManager is the interface that is used to control and configure the ThinServer.

### 5.3. Redundant ThinManagers

Because each ThinManager Ready thin client needs to contact ThinManager to retrieve its configuration the use of a second redundant ThinManager Server can be useful to prevent downtime due to the loss of the primary ThinManager Server. Redundant ThinManager Servers should be synchronized so that it doesn’t matter which ThinManager Server the thin client boots from.

#### 5.3.1. Failover versus Redundancy

- A ThinManager Ready thin client needs to connect to a ThinManager Server and receive its configuration.
- This configuration sends the ThinManager Ready thin client to a terminal server(s) to start a session and run.
- **Redundancy** describes having two ThinManager Servers so that a ThinManager Ready thin client can always find a ThinManager Server to boot from and receive its configuration.
- **Failover** describes having multiple terminal servers that the thin client is assigned to so that it always has a terminal server it can connect and start a session.

**Note:** When a ThinManager Ready thin client boots it loads its configuration into memory. If ThinManager fails the thin client will continue to run until it is rebooted and the memory is cleared.

#### 5.3.2. Single ThinManager

- Install ThinManager on a single computer.
- Install a Master License with the needed Product Licenses on this computer.

#### 5.3.3. Full Redundancy

Full Redundancy uses two synchronized ThinServer engines and has two ThinManager interfaces for control on either computer.

- Install ThinManager on two computers.
- Purchase a Redundant ThinManager Product License(s).
Auto-synchronize the ThinManager Servers as described in section so that the Install IDs of both ThinManager Servers are displayed in the Licensing Window (Install>Licenses on the ThinManager menu bar).

Create a Master License with Full Redundancy. Add the Product Licenses, activate and apply. See section 6.1.

Configure each ThinManager Ready thin client to boot from both ThinManager Servers.

5.3.4. Mirrored Redundancy
Mirrored Redundancy uses two synchronized ThinServer engines but allows administrative functions only on the designated primary ThinManager Server.

Install ThinManager on two computers.

Purchase a Mirrored ThinManager Product License(s).

Auto-synchronize the ThinManager Servers as described in section so that the Install IDs of both ThinManager Servers are displayed in the Licensing Window (Install>Licenses on the ThinManager menu bar).

Create a Master License with Mirrored Redundancy. Add the Product Licenses, activate and apply. See section 6.1.

Configure each ThinManager Ready thin client to boot from both ThinManager Servers.

5.3.5. Auto-Synchronization

Open the ThinManager Server List Wizard by selecting Manage> ThinManager Server List from the ThinManager menu bar.

Select the Automatic Synchronization checkbox on the Auto-synchronization Selection window.

Define the primary and secondary ThinManager Servers by selecting the Edit button and adding the server name and IP address.

Select the Finish button to accept the change.

5.3.6. Manual Synchronization

Note: Auto-synchronization is the recommended method of keeping the configuration of two ThinManager Servers identical. See section 5.3.5.

Open the ThinManager Server List Wizard by selecting Manage> ThinManager Server List from the ThinManager menu bar.

Leave the Automatic Synchronization checkbox on the Auto-synchronization Selection window unchecked.

Define the ThinManager Servers on the ThinManager Server List page by selecting the Add Server button.

Close the ThinManager Server List Wizard by selecting the Finish button.

Select Manage>Synchronize Configuration from the ThinManager menu bar.
Highlight the primary ThinManager Server in the Configuration Source list.

Highlight the secondary ThinManager Server in the Configuration Destination list.

Select Next twice to confirm the synchronization choices.

Select Finish to initiate the synchronization. The configuration from the primary ThinManager Server will overwrite the configuration on the secondary ThinManager Server.

6. ThinManager Licensing

The process of activating licenses is covered in Section 6.1.

The types and styles for licenses are covered in Section 6.2.

6.1. Master Licenses

ThinManager requires a license for each terminal that connects through ThinManager. These are assigned when the terminal retrieves its configuration.

- Licenses should be activated in the name of the end customer and not the name of a system integrator or consultant.
- ThinManager 4 uses a Master License. This acts as a basket to hold the individual Product Licenses.
- Master Licenses are created and activated through the ThinManager web site. The activation process requires Product License Numbers and an Installation ID.
- The Product License Number is the purchased “paper” license.
- The Install ID ties the license to the hardware. It is found on the Licensing Window by selecting Install>Licenses from the ThinManager menu bar.
- The downloaded master license file is installed through ThinManager.

6.1.1. ACP License Account

- Each person who wants to access the license database needs to register on the License Activation site by creating an account with contact information for the user. This user account allows the user to activate licenses.
- Select the New User link at the ThinManager website at www.thinmanager.com, and fill out the appropriate fields to create the account.
- Once the account is created the password of the account will be sent to the e-mail address defined in the account.

6.1.2. Master License Creation

- ThinManager licenses are activated at the ThinManager website at www.thinmanager.com. A License Activation link will be prominently displayed on the main page.
- Select the ThinManager 4.0 License link.
The licensee needs to login to the License Activation site with their created user account. See section 6.1.1.

The logged-in user should select the Create Master License link in the sidebar.

Enter a description of the ThinManager Server and its location in the Server Name/Site Description fields. Enter the end user information in the Company Name and Address fields.

Select the level of redundancy to be used, either None, Mirrored, or Full Redundancy. See 5.3 for details.

Select the Submit button to create the Master License.

### 6.1.3. Adding Product Licenses to Master License

A Master License without a Product License is an empty container. Product Licenses need to be added to the Master License. The Product License Number is the purchased “paper” license, equivalent to the ThinManager 3 license. It may be found inside the ThinManager 4 CD case.

Select the Manage Master Licenses link in the sidebar of the licensing web site.
A list of all the master licenses will be displayed.

Select the Add Product License link in the table for your master license. Add the product license in the field that is displayed.
Repeat for each product license.

### 6.1.4. Activating the Master License

The Master License needs activated once the product license(s) have been added.

Select the Activate License link in the table for your master license.

Enter the Installation ID in its field. The Installation ID is found by selecting Install>Licenses in ThinManager to display the Licensing window.

If you are using Redundancy or Mirrored Redundancy you need to enter both the primary and secondary installation Ids in the proper fields. The Ids are in the Licensing window of ThinManager.

Select Submit to download the file. Don’t save it in the ThinManager folder but save it to a directory that ThinManager has access to.

---

**Note:** If you only have one ThinManager Server ready when first bringing a system online you can activate a Redundant or Mirrored Master License with just the primary Install ID. You can reactivate it with both the primary and secondary Install Ids later when both ThinManager Servers are ready.
6.1.5. Installing the Master License

- Open the Licensing window in ThinManager by selecting Install>Licenses from the menu.
- Select the Install License button. Browse to the downloaded master license file and select Open. ThinManager will install the file.

6.1.6. Single Product Licenses on Redundant Master License

- You can add a non-redundant product license to a redundant master license using the steps described in 6.1.3. You will be asked to assign the product license to either the primary or backup ThinManager Server.

6.1.7. Reactivating Licenses

- The master license will need reactivated each time a product license is added.

6.2. License Types

- The basic license is a Terminal Connection License. This allows a ThinManager Ready thin client to receive its configuration.
- ThinManager 4 includes the following into the basic Terminal Connection license:
  - MultiSession
  - SmartSession
  - Instant Failover
  - Redundant Ethernet
  - Terminal-to-Terminal Shadow
  - Share Keyboard and Mouse
- WinTMC and MultiMonitor licenses are sold separately from the Terminal Connection licenses.
- ThinManager 4 includes 5 per-user TermSecure licenses with the installation.

ThinManager has two licensing models, the Enterprise with unlimited connections and the Standard with 5, 10, and 25-connection packs.

6.3. Enterprise Licenses

- Enterprise Licenses provide unlimited connections of terminals and full redundancy.
- They are available as Enterprise Server and Enterprise Site.
- MultiMonitor and WinTMC licenses are sold separately.

6.3.1. Enterprise Server

- Enterprise Server provides licenses for two ThinManager Servers for full redundancy.
The redundant ThinManager Servers are licensed with a Redundant Master License that uses the Install IDs from both ThinManager Servers.

Each ThinManager Server can run the ThinManager interface for configuration and control.

ThinManager Ready thin clients should be configured to boot from both ThinManager Servers.

The two ThinManager Servers should be auto-synchronized so that the configurations are the same. See section 6.3.2.

6.3.2. Enterprise Site

Enterprise Site allows a customer to install as many ThinManager Servers as desired on one site.

The Enterprise Site is a single license number that can be installed on many computers at that site.

Redundant pairs of ThinManager Servers are recommended for full redundancy.

Each ThinManager Server or redundant pair of ThinManager Servers will need a master license. The Enterprise License is added as the product license.

Enterprise Site allows departmental control by having multiple redundant pairs of ThinManager Servers.

6.4. Standard Licenses

Standard Licenses provide licenses in packs of 5, 10, and 25 connections.

ThinManager 4 has four standard licenses:

- Terminal Connections – basic ThinManager license
- WinTMC – For turning PCs in to managed fat clients
- MultiMonitor – For MultiMonitor hardware, available in 1-packs.
- TermSecure – ThinManager 4 includes 5 TermSecure licenses. Additional users are available as standard licenses.

ThinManager 4 includes the following into the basic Terminal Connection license:

- MultiSession
- SmartSession
- Instant Failover
- Redundant Ethernet
- Terminal-to-Terminal Shadow
- Share Keyboard and Mouse

WinTMC, MultiMonitor, and additional TermSecure licenses are sold separately from the Terminal Connection licenses.

The standard licenses are added to your Master License as Product Licenses. See 6.1.3.
7. Hardware Configuration
ThinManager Ready thin clients need little configuration at the terminal except an IP address and the IP address of a ThinManager Server to connect on the network. Units are shipped using DHCP by default but can be configured to use static IPs.

7.1. IP Addressing

7.1.1. DHCP Only
- ThinManager Ready thin clients are set by default to use DHCP to receive their IP address.
- The DHCP server needs Option 066 – Boot Server Host Name configured to list the IP address of the ThinManager Server. Redundant ThinManager Servers can be listed, separated by a space. See Hybrid IP (DHCP & Static) in section 7.1.3 for another method.
- Launch the Scope Options page by opening the DHCP Server, highlighting the Scope Options, and selecting Action>Configure Options.
- Check the 066 Boot Server Host Name checkbox, enter the ThinManager Server IP address in the String value, and select the OK button field.
- Redundant ThinManager Servers can be defined by listing the IP addresses of both, separated by a space.
- Set the Conflict detection attempts on the DHCP Properties, Advanced tab of the DHCP Server to one or more.

7.1.2. Static IP Only
- ThinManager Ready thin clients can be configured to use static IP by pressing the space bar during the thin client boot when the “Press Any Key to Configure IP Addresses” message is displayed.
- Select “A” to define the terminal IP. Enter the desired IP and select the Enter key.
- Select “B” to define the primary ThinManager Server. Enter the desired IP and select the Enter key.
- Select “C” to define the secondary ThinManager Server if you have redundant ThinManager Servers. Enter the desired IP and select the Enter key.
- Select “S” to save the configuration and continue with the boot process.

7.1.3. Hybrid IP (DHCP & Static)
ThinManager Ready thin clients can be configured to use DHCP to assign the terminal IP address but use a static IP address for the ThinManager Server. This allows a DHCP server to be used without configuring Option 066.
- Enter the IP Configuration menu by pressing the space bar during the thin client boot when the “Press Any Key to Configure IP Addresses” message is displayed.
- Leave “A” alone to keep it using DHCP for the terminal IP address.
Select “B” to define the primary ThinManager Server. Enter the desired IP and select the Enter key.

Select “C” to define the secondary ThinManager Server if you have redundant ThinManager Servers. Enter the desired IP and select the Enter key.

Select “S” to save the configuration and continue with the boot process.

8. **ThinManager Configuration**

ThinManager uses Wizards to aid in the configuration of the terminals.

The wizards can be run to pre-configure the terminals or the wizards can be launched automatically when the new terminal is connected to ThinManager for the first time.

Note: If in doubt, the default settings are your friends.

8.1. **Terminal Configuration**

Launch the Terminal Configuration Wizard by selecting Edit>Add Terminal from the ThinManager menu or by right clicking on the Terminals branch of the tree and selecting Add Terminal. If a terminal is connected to ThinManager without a configuration it will launch the wizard automatically.

Proceed through the pages of the wizard. The highlights are:

- Terminal Name - Enter the desired name of the terminal. This name should be 15 characters or less.
- Terminal Hardware - Select the hardware make and model. This is optional, as the terminal will correctly identify itself when it connects to ThinManager. WinTMC clients need to use GENERIC/PersonalComputer in the Make/Model drop-down.
- Terminal Options – Shadow access can be controlled in the Shadowing section.
- Terminal Mode Selection – Choose Use Display Clients to use AppLink, MultiSession, SmartSession, and MultiMonitor. Chose Enable TermSecure to use TermSecure on the terminal.
- Display Client Selection – Apply Display Clients to the terminal by them to the Selected Display Clients list on the right. If Display Clients haven’t been defined then select the Edit Display Clients button to launch the needed configuration wizard.
- Terminal Interface Options and Hotkey Configuration – A terminal using multiple Display Clients need a method to switch between sessions. These are configured on these two pages.
- Log In Information - Enter a valid Windows user name and password into the Username and Password fields if you want the terminal to automatically login when it connects to the terminal server.
- Video Resolution - Set the desired video resolution for the terminal.
- Module Selection - Add any modules that are needed by selecting the Add button. See Modules in section 11 for details.
ThinManager Server Monitor List – You can have the terminal send the monitoring status to both ThinManager Servers when using redundancy by listing both ThinManager Servers in the Selected ThinManager Server list. Define your ThinManager Servers by selecting the Edit Server List button on the page. This is done automatically when using Auto-synchronization.

Monitoring Configuration – This sets the rate at which the terminal polls the terminal server to determine if the terminal server is available for connections.

If the wizard was launched when the terminal connected to ThinManager it will continue to boot and login as defined once the Finish button is selected. If the wizard was run as a pre-configuration, this profile will be available for selection when new hardware is added.

8.1.1. Terminal Group Configuration

Terminals can be organized by adding them to a Terminal Group.

Groups can be nested into other Groups.

A Terminal Group is created by selecting Edit>Add Terminal Group from the ThinManager menu. The Group Configuration Wizard resembles the Terminal Configuration Wizard with the addition of the Group Setting checkbox.

A property that is set as Group Settings is applied to everybody in that group.

Terminals can join a group by the selection of the Change Group button on the Terminal Name page of the Terminal Configuration Wizard.

8.2. Display Servers

Display Servers are devices that provide content that can be displayed on the client. Examples include the traditional terminal server and IP cameras.

The Terminal Server List Wizard allows configuration of Terminal Services Display Servers.

The Camera Configuration Wizard allows configuration of Camera Display Servers. See 8.2.2.

8.2.1. Terminal Server Configuration

Terminal servers are defined in the Terminal Server Wizard. This can be launched by right clicking on the Terminal Servers branch of the ThinManager tree and selecting Add Terminal Server.

Proceed through the pages of the wizard. The highlights are:

- Terminal Server Name - Enter the Microsoft computer name in the Terminal Server Name field.
- Terminal Server Name - Enter the IP address in the Terminal Server IP field or use the Discover button to automatically fill in the IP address.
- Terminal Server Name - Enter the user name and password for an administrative account on the terminal server into the User Name and Password field to allow ThinManager to import the Terminal Services Manager...
information into ThinManager. This is important for SmartSession load balancing.

- Terminal Server Capabilities - Select *Available for Display Clients using SmartSession Groups* if the terminal server will be used for SmartSession.

- Data Gathering - Select a Data Gathering Interval. This is the frequency that ThinManager polls the terminal server for the Terminal Services Manager information. Select the *Next* button to continue.

- SmartSession Configuration - This allows the SmartSession parameters to be changed from the defaults.

Note: If in doubt, the default settings are your friends.

### 8.2.2. Camera Configuration

- IP cameras are defined as Display Servers. Their output is configured as a Display Client. See 8.3.3.

- Cameras are defined in the Camera Configuration Wizard. This can be launched by right clicking on the Camera branch of the ThinManager tree and selecting *Add Camera*.

Proceed through the pages of the wizard. The highlights are:

- Camera Name - Enter a name for the camera in the *Camera Name* field.

- Camera Name – Select the *Make* and *Model* in the drop-downs or leave the default settings.

- Camera Name – Enter the camera IP address and port. See the camera documentation for instructions on setting these.

- Camera Authentication – Add a *Username* and *Password* if required. Select *Finish* to complete.

### 8.3. Display Client Configuration

Display Client is the term used to denote the graphic rendering of the output from a Display Server. This could be a traditional Terminal Server session, IP Camera display, or a Terminal-to-Terminal Shadow session.

#### 8.3.1. Terminal Services Display Clients

- Terminal Services Display Clients are defined in the Display Client Wizard. This can be launched by right clicking on Terminal Services in the Display Client branch of the ThinManager tree and selecting *Add Display Client*.

Proceed through the pages of the wizard. The highlights are:

- Client Name - Select Terminal Services in the *Type Display Client* drop-down.

- Client Name - Enter the name of the Display Client in the *Client Name* field.

- Display Client Options – Select the *Allow Display Client to be tiled* checkbox if you want to use Session Tiling. See section 14.6.

- Display Client Options – Select the *Include IP Camera Overlays* checkbox if you want to add camera output to the Display Client.
Terminal Services Display Client Type – Choose the default Remote Desktop Protocol or other protocol to use for client communication.

Terminal Services Display Client Options – Select the options needed:
- **SmartSession** for load balancing.
- **Application Link** for application deployment.
- **Enforce Primary** to set one computer as the preferred terminal server.
- **Instant Failover** to launch two instances of the application for quick failover.
- **Allow Auto-Login** to let the session start automatically. Uncheck this to force the user to manually login.

Display Client Members - Select the terminal servers that should be used by the Display Client by moving the desired terminal servers into the Selected Terminal Servers list. Select the Edit Server List button to launch the Terminal Server Configuration Wizard if you need to define terminal servers.

SmartSession Settings - If the Display Client uses SmartSession you can change the SmartSession settings from the defaults, if needed.

AppLink - Enter the path to a program in the AppLink Path field if you want the Display Client to run a specific program instead of a desktop.

Select the Finish button to complete the Display Client configuration.

**8.3.2. Terminal Shadow Display Client**

Terminal Shadow Display Clients are defined in the Display Client Wizard. This can be launched by right clicking on Terminal Shadow in the Display Client branch of the ThinManager tree and selecting Add Display Client.

Proceed through the pages of the wizard. The highlights are:

- **Client Name** - Enter the name of the Display Client in the Group Name field.
- **Client Name** - Select Terminal Shadow in the Type of Display Client dropdown.
- **Display Client Options** – Select the Allow Display Client to be tiled checkbox if you want to use SessionTiling. See section 14.6.
- **Display Client Options** – Select the Include IP Camera Overlays checkbox if you want to add camera output to the Display Client.
- **Terminal Shadow Display Client** – Leave the All Terminals Available checkbox selected to allow any terminal to be shadowed or un-select it and use the Add button to add one or more terminal to the list or available terminals to shadow.
- **Terminal Shadow Display Client** – Leave the Interactive Shadow checkbox selected to allow the user to control the shadowed session or un-select it to limit a user to viewing the session.
8.3.3. Camera Display Clients

- Camera Display Clients are defined in the Display Client Wizard. This can be launched by right clicking on Camera in the Display Client branch of the ThinManager tree and selecting Add Display Client.

Proceed through the pages of the wizard. The highlights are:

- Client Name - Enter the name of the Display Client in the Group Name field.
- Client Name - Select Camera in the Type of Display Client drop-down.
- Display Client Options – Select the Allow Display Client to be tiled checkbox if you want to use SessionTiling. See section 14.6.
- Overlay Layout – Select the layout format from the Choose Camera Layout drop-down.
- Overlay Cameras – A page will be displayed for each layout. You can let the user choose from all the cameras by selecting the All Cameras Available or you an unselect that and add cameras with the Add button.

9. MultiSession

MultiSession allows a user to run several Display Client sessions on one terminal. These will be cascaded on the terminal.

MultiSession, when used with AppLink, is an easy way to deploy desired applications while preventing access to unauthorized programs.

MultiSession is included in ThinManager 4 and Terminal servers and Display Clients no longer need to be configured for MultiSession. Adding two or more Display Clients to a terminal enables MultiSession.

9.1. Configuring the Terminal for MultiSession


- Select two or Display Clients on the Display Client Selection page of the Terminal Configuration Wizard.

- The terminal needs a method to switch between sessions. This is configured on the Terminal Interface Options and Hotkey Configuration pages of the Terminal Configuration Wizard. See section 9.2.

- If the terminal is set to auto-login then it will auto-login to the MultiSession sessions. A Display Client can be set to force manual logins for authentication by unselecting the Allow Auto-Login checkbox on the Group Options page of the Display Client Wizard.

- A Display Client can use a different login than the terminal by using the Override button on the Display Client Selection page of the Terminal Configuration Wizard.
9.2. Switching Between Sessions

- Each terminal that uses MultiSession should be configured to switch between sessions on the Terminal Interface Options and the Hotkey Configuration pages of the Terminal Configuration Wizard. At least one method must be used.

- Terminal Interface Options - *Show Group Selector on Terminal* will display a drop-down menu on the terminal's screen. The default auto-hide mode can be removed by selecting the *Selector Options* button.

- Terminal Interface Options – *Enable Tiling* will tile the sessions to allow a visual selection of a session. See section 14.6.

- Terminal Interface Options - *Screen Edge Selection* will switch between sessions when the mouse is moved to the left or right edge.

- Hotkey Configuration - *Enable Group Hotkeys* will allow keystrokes to switch the session displayed. The default CTL+Page Up/Down can be changed by selecting the *Change Hotkeys* button.

10. **SmartSession**

SmartSession provides load balancing among designated terminal servers.

10.1. Configuring the Terminal Server Display Server

- Terminal servers are configured to use SmartSession by selecting the *Available for Display Clients using SmartSession* checkbox on the Terminal Server Capabilities page of the Terminal Server Wizard.

- SmartSession requires that ThinManager be able to pull memory, CPU, and session data from the terminal server. This requires the username and password from a valid Windows administrator account to be entered in the *Username* and *Password* fields of the Terminal Server Name page of the Terminal Server Wizard.

- The frequency of the data polling is set on the Data Gathering page of the Terminal Server Wizard.

- The SmartSession Configuration page allows the ranges of the CPU, Memory, and Session count to be adjusted. (The defaults are your friends).
10.2. Configuring the SmartSession Display Client

- Terminal Services Display Clients can be configured to use SmartSession for load balancing.
- A Display Client becomes load balanced when the SmartSession checkbox on the Terminal Server Display Client Options page of the Display Client Wizard is selected.
- Only terminal servers that have been configured to use SmartSession will be available for selection on the Display Client Members page of the Display Client Wizard.
- ThinManager polls the SmartSession terminal servers and calculates a Server Rank number based on the CPU, Memory, and Session resources used. A terminal connecting to a Display Client using SmartSession will be sent by ThinManager to the terminal server with the most available resources as defined by the lowest server rank number.
- The weight of the SmartSession values can be adjusted on the SmartSession Settings page of the Display Client Wizard.
- The Server Rank number for the SmartSession servers can be displayed by highlighting a Display Client using SmartSession in the ThinManager tree and selecting the Server Rank tab in the Details pane.

10.2.1. SmartSession Queuing

- SmartSession Queuing allows ThinManager to control the rate that terminals connect to the terminal servers to prevent the server CPU from becoming overloaded and slowing down the session connection process.
- Queuing is configured on the SmartSession Settings page of the Display Client Wizard for display clients using SmartSession.
- When a CPU reaches the maximum CPU Utilization, as defined on the SmartSession Configuration page of the Terminal Server Wizard, ThinManager will delay other terminals from connecting until the CPU utilization returns to a normal level or the maximum Queuing Time on the SmartSession Settings page of the Display Client Wizard is reached.
- A SmartSession Display Client can contain a single terminal server to control the loading of that server as clients connect.

11. Modules

Modules are optional features or programs that aren’t needed to run a basic thin client but can be added to expand the functions. These include screen savers, touch screen drivers, sound modules, and others.

- Modules are installed on the Module Selection page of the Terminal Configuration Wizard.
- Select the Add button to add a module.
- Select the desired module from the list and select the OK button. The modules can be sorted by module type to filter the selections.
Some modules have configurable parameters. To change them highlight the added module in the Installed Module window of the Module Selection page and select the Configure button to launch the Module Properties window.

Highlight the desired parameter to activate the Value field. Use the drop-down to change the setting then select the Set button to apply the parameter change. Select the Done button when all the parameters are set.

Select the Finish button to apply the changes and restart the thin client to send the configuration change to the thin client.

11.1. Updating Modules

New modules can be downloaded from the ThinManager web site at www.thinmanager.com/support/downloads.shtml#modules.

Register the new module by selecting Install>Modules from the ThinManager menu bar and selecting the Install Module button. Browse to the downloaded module and select the Open button. This will add the module to the list of available modules.

12. **WinTMC**

WinTMC is a Windows client that can be installed on PCs but is controlled through ThinManager.

12.1. **WinTMC Advantages**

- WinTMC can convert PC to a terminal services client reducing local maintenance of applications.
- PC becomes managed by ThinManager, allowing failover, Instant Failover, MultiSession, and SmartSession functions.
- Applications that aren’t terminal services compliant like AutoCAD can be run locally while gaining management benefits from running other applications on terminal servers.

12.2. **WinTMC Disadvantages**

- The PC that WinTMC is installed on still requires installation and maintenance of its operating system.
- Modules won’t work because ThinManager doesn’t control the operating system. These functions must be setup and controlled using the PC operating system. These include:
  - Touch screen drivers
  - Sound drivers
  - Local storage
  - Mouse
  - Screen savers
- Instant Failover is supported by WinTMC. TermSecure is supported by WinTMC v2.0 (Black & Blue icon). MultiMonitor is supported on PCs with multiple monitors.
12.3. WinTMC Installation

**Note:** WinTMC should not be installed on the ThinManager Server due to a conflict over port 2031. It is meant to be installed on PCs.

- Install the WinTMC application on the desired PC.
- Using the *Add/Remove Programs* tool is recommended for installations.
- WinTMC allows two options during installation:
  - WinTMC is the WinTMC client needed to turn the PC into a terminal.
  - WinTMC Shadow Service is needed to shadow a WinTMC client. If this program is installed, the PC can be shadowed from ThinManager even if the WinTMC client is inactive.

12.4. WinTMC Configuration on the Client

- Once installed, launch the WinTMC program from the Windows Start menu or from a desktop icon.
- Select the *Configure* button on the splash screen when it is first run.
- Enter the IP address of the ThinManager Server(s) in the *Enter new ThinManager Server Name or IP Address* field and select the *Add* button.
- Select the *OK* button to connect to the ThinManager Server.
- The Terminal Replacement Dialog window will display any off-line terminals and a *Create a new terminal* button. Select a pre-created terminal to assume an established configuration or select the *Create a new terminal* button to launch the Terminal Configuration Wizard for that WinTMC client on the ThinManager Server.

12.5. WinTMC Configuration in ThinManager

- Pre-create a WinTMC client by launching the Terminal Configuration Wizard by selecting *Edit>Add Terminal* from the ThinManager menu bar. The configuration is similar to thin clients with a few exceptions.
- Add the computer name for the terminal name in the Terminal Name page of the wizard.
- Select *GENERIC* for the Make/OEM and *PersonalComputer* for the Model on the Terminal Hardware page of the wizard.
- Select the video resolution on the Video Resolution page. The default is *FullScreen*.
- Select the *Finish* button when the configuration is complete.

13. Shadowing

Shadowing allows a user to view a terminal. It is available in two forms:

- Terminal Shadowing through ThinManager.
- Terminal-to-terminal shadowing through Terminal Shadow Display Clients.
13.1. ThinManager Shadowing

- Terminal Shadowing through ThinManager allows an administrator to see what is displayed on a terminal’s screen.

- A terminal is shadowed by highlighting the terminal in the ThinManager tree and selecting the Shadow tab on the Details pane.

- To shadow a user must be either a member of the Administrators user group in Windows or a member of a Windows user groups that was granted permission to shadow on the ThinManager Security Groups page of the ThinManager Server Configuration Wizard.

- Shadow settings are configured on the Terminal Options page of the Terminal Configuration Wizard. The terminal can be set to block shadowing (NO), ask user permission first (ASK), warn the user first (WARN), or shadow immediately (YES).

- Interactive Shadow allows the administrator to control the shadowed session. This can be allowed/disallowed on the Terminal Options page of the Terminal Configuration Wizard. It can also be turned off/on by selecting RemoteView>Interactive Shadow on the ThinManager menu.

- WinTMC requires that the WinTMC Shadow Service be installed on the client PC. Once the PC has been connected to ThinManager the PC can be shadowed even if WinTMC is not running.

- The WinTMC shadow service uses Port 5900. If this is in conflict with another program it can be changed on the Shadow Configuration page of the ThinManager Server Configuration Wizard.

13.2. Terminal Shadow Display Client

- Terminal-to-terminal shadowing through Terminal Shadow Display Clients allows any user on a terminal with the Terminal Shadow group to shadow a terminal that is in the Terminal Shadow group. See section 8.3.2 for configuration.

- The Terminal Shadow Display Client can be configured to show a specific terminal or present a list of terminals for the operator to choose from.

14. Additional Topics

14.1. MultiMonitor

- MultiMonitor allows a single ThinManager Ready thin client to have up to 5 monitors attached at the same time.

- The monitors can be combined into larger “spanned” screens (double-wide/triple-wide/etc.) or run as individual single-monitor “screens”.

- Each monitor can be of a different video resolution or use a different touch screen. However monitors that are combined to form a spanned screen must have the same resolution.

- MultiMonitor requires a MultiMonitor license in addition to the Terminal Connection or Enterprise license.
One MultiMonitor license covers one thin client terminal; you don’t need a license per monitor.

MultiMonitor requires the use of Display Clients.

14.1.1. Configuring MultiMonitor

- MultiMonitor is configured in the Terminal Configuration Wizard.
- Terminal Hardware page – Select the Make and Model of the MultiMonitor ThinManager Ready thin client.
- Terminal Mode Selection page – Select Enable MultiMonitor.
- MultiMonitor Video Settings page – Select the Number of Monitors and the video resolution of each.
- Monitor Layout page – Select the physical layout of the monitors in the Choose your monitor layout window. The Main Monitor is the monitor that will display login and message windows.
- Monitor Layout page – Select how the monitors will be combined in the Choose your screen layout window. Choose whether the monitors are combined as “spanned” or kept individual as “screened”. The TermSecure Initial Screen is the monitor that will display TermSecure login and message windows if TermSecure is used.
- Display Client Selection page – Select which Display Client(s) will be displayed on which screen by highlighting the desired Display Client and selecting the appropriate arrow.
- Screen Options page – This configures options like the ability to move sessions, which monitor in a spanned group is the main monitor, and how MultiSession switching should take place.
- Hotkey Configuration page – This configures hotkey options for MultiSession and SessionTiling.

14.1.2. MultiMonitor WinTMC Clients

- MultiMonitor is supported by WinTMC clients that are running on a computer with two or more monitors.
- The WinTMC client can be configured to use “spanned” screens (double-wide/triple-wide/etc.) or run as individual single-monitor “screens”.

14.2. Reports

- ThinManager has reports that can be displayed to show events and configurations.
- Selecting View>Reports will allow the administrator to select what reports will be displayed.
- Reports are shown by highlighting an item in the ThinManager tree and selecting the Report tab in the Details pane.
New reports can be added by selecting \textit{Install>Reports>Install} in the ThinManager menu. Each report has a Report Template and a SQL Query component.

Reports can be run automatically and saved as *.html files using the Scheduler on the System Schedule page of the ThinManager Server Configuration Wizard.

The Report tab can be printed by selecting \textit{View > Print} from the menu bar.

\subsection{14.3. Touch Screens}

Touch screens are activated by adding the appropriate Touch Screen module on the Module Selection page of the Terminal Configuration Wizard.

The module needs to match the make of the touch screen controller. The make of the monitor is incidental.

Touch screen parameters can be changed by highlighting the module on the Module Selection page of the Terminal Configuration Wizard and selecting the \textit{Configure} button.

Touch screens can be configured so that a touch that is held will count as a right click or will initiate the calibration program.

The terminal can be calibrated by highlighting the terminal in the ThinManager tree and selecting \textit{Tools> Calibrate Touch Screen} on the menu.

A MultiMonitor thin client will need a touch screen module for each touch screen used. The monitor number is set by selecting the \textit{Configure} button when the module is highlighted. A different touch screen can be applied to each monitor if needed.

\subsection{14.4. Event Log}

ThinManager has an event log that can be displayed by highlighting an item in the ThinManager tree and selecting the Event Log tab in the Details pane.

The Event Log is configured on the Historical Logging page of the ThinManager Server Configuration Wizard. The events to track and the duration of the event log are configurable.

The Event Log can be backed up automatically using the Scheduler on the System Schedule page of the ThinManager Server Configuration Wizard.

\subsection{14.5. Security}

ThinManager is designed to increase security.

ThinManager can be run only by administrators or members of Windows user groups that have been given permission on the ThinManager Security Groups page of the ThinManager Server Configuration Wizard.

Terminals can be configured to login automatically. This obscures the username and password so that a user doesn’t know the account credentials to try to access other resources.

AppLink can limit a user to specific programs and block access to the desktop or unauthorized programs.
The Key Block module can be set to trap undesired keystrokes.
TermSecure can be used to provide addition access control and management.

### 14.6. Scheduling

- The **Schedule** button on the Terminal Options page of the Terminal Configuration Wizard allows a terminal to be disabled, enabled, or rebooted automatically on a schedule.
- The **Schedule** button on the System Schedule page of the ThinManager Server Configuration Wizard allows the configuration to be backed up or reports run automatically on a schedule.
- A weekly backup the configuration with System Schedule tool is recommended.

### 14.7. SessionTiling

- The sessions started using MultiSession can be tiled on a terminal to display all sessions at once.
- This might be to monitor all the sessions at once or as a visual selection aid on terminals with touch screens that lack a keyboard for hotkey switching.
- Selecting the **Enable Tiling** checkbox on the Terminal Interface Options page of the Terminal Configuration Wizard enables SessionTiling. The **Tiling Options** button allows the tiling parameters to be configured.

### 15. Failover and Instant Failover

#### 15.1. Definitions

##### 15.1.1. Failover versus Redundancy

- **Redundancy** describes having two ThinManager Servers so that a ThinManager Ready thin client can always find a ThinManager Server to boot from and receive its configuration.
- **Failover** describes having multiple terminal servers that the thin client is assigned to so that it always has a terminal server it can connect to and start a session.

##### 15.1.2. Failover Explained

- In Failover a ThinManager Ready thin client is assigned to a list of terminal servers and will connect to the first one on the list.
- The ThinManager Ready thin client will detect if that terminal server fails and will connect to the next terminal server on the list. This normally takes 10-20 seconds.
- Once the thin client connects to the backup terminal server it will login and launch its application. The application launch can take 5 seconds to 3 minutes depending on the application and the terminal server load.
- All versions of ThinManager provide the failover function for free.
15.1.3. Instant Failover Explained

- Instant Failover configures the ThinManager Ready thin client to connect to two terminal servers and launch a session on each at the same time.
- The terminal should be configured to auto-login and launch an initial program to gain the full benefits of Instant Failover.
- The sessions are cascaded on the terminal monitor.
- A failure of the primary terminal server will cause the terminal to switch to the backup session. Since the session and application are already initialized this takes just a second.
- If the terminal is assigned to three or more terminal servers the terminal will then start a second session on the next available terminal server.
- Instant Failover can be configured so that the user can switch between active sessions using the \textit{CTL + F9} hotkey.
- The Instant Failover function is now included in the ThinManager 4 Terminal Connection license. It may require an second application license since you will have two active sessions.

15.2. Failover Configuration

Standard failover is configured by providing the ThinManager Ready thin client a list of terminal servers for connection.

The method of failover differs if the terminal is using individual terminal servers or Display Clients, as configured on the Terminal Mode Selection page of the Terminal Configuration Wizard.

Using Display Clients is the preferred method.

- Failover is configured within a Display Client group by adding two or more terminal servers to the \textit{Selected Terminal Servers} list on the Display Client Members page of the Terminal Services Display Client Wizard.
- Open the Display Client Wizard by double-clicking on the Display Client icon in the ThinManager tree.
- Add two or more terminal servers to the \textit{Selected Terminal Servers} list on the Display Client Members page.
- The terminal will connect to the terminal servers in the order listed unless the Display Client has been configured for SmartSession.
- Terminals will connect to the terminal servers in a SmartSession group based on their load, from the lightest to the heaviest load.
- Selecting the \textit{Enforce Primary} checkbox on the Terminal Services Display Client Group Options page of the Display Client Wizard activates the Enforce Primary function. Enforce Primary is not available for SmartSession groups.

15.3. Instant Failover Configuration

Instant Failover enables a terminal to login and create a session on two terminal servers so that the backup session is initialized for a quick switch.
The method of failover differs if the terminal is using individual terminal servers or Display Clients, as configured on the Terminal Mode Selection page of the Terminal Configuration Wizard.

Using Display Clients is the preferred method.

- Instant Failover is configured within a Display Client for terminals that use Display Clients.
- The Instant Failover module should not be used with Display Clients.
- Open the Display Client wizard by double-clicking on the Terminal Services Display Client in the ThinManager tree.
- Navigate to the Terminal Services Display Client Options page of the Display Client Wizard and select the Instant Failover checkbox.
- Select two or more terminal servers for the Display Client by adding them to the Selected Terminal Servers list on the Display Client Members page of the Display Client Wizard. Select the Finish button to accept the changes.
- Add the Instant Failover Display Client to a terminal by opening the Terminal Configuration Wizard for the terminal by double-clicking on it in the ThinManager Tree.
- Expanding a Display Client configured for Instant Failover will show the terminal servers that are assigned to the group. A green lighting bolt shows the active session that is on top of the screen while a yellow lightning bolt will show the backup session that is hidden.
- The Hotkey Configuration page in the Terminal Configuration Wizard allows hotkey options for Instant Failover to be configured.
16. **ThinManager Troubleshooting Guide**

This is a list of common configuration errors and a guide for fixing them.

**Note:** When any problem arises, check Downloads at [www.thinmanager.com](http://www.thinmanager.com) for the latest firmware. The problem you are experiencing may have already been fixed and released in a later version of firmware and using the latest version will cure the current problem. Try applying the latest firmware, and then reboot the thin client to see if the problem still exists. The current version is backwards compatible to earlier versions of ThinManager.

16.1. **From Power on to Terminal Server Login**

1) **Powering on the Thin Client**
   - **A) No Power**
     - Check power cable, power supply, and power outlets.
   - **B) No Video**
     - Check video cable and monitor.
     
     **Warning:** Never go into the thin client BIOS and change the *Integrated Peripherals>Display Status* from CRT to LCD. This changes the video output of the motherboard from the VGA port to a socket on the motherboard used for integrated LCD panels. Changing this from CRT will prevent any video from being displayed on a monitor.

2) **Booting - ACP Network Boot Loader**
   - **A) Cannot get IP address using DHCP**
     - Is the ThinManager Ready thin client set to DHCP? They are set to DHCP by default, but can be changed.
     - Is the Thin Client on the same side of the router as the DHCP server?
     - Does the DHCP server have addresses to give out?
   - **B) Cannot get IP address using Static IP menu**
     - Certain models (ThinAdapters and older DC-40-100s with black PS/2 ports) cannot use static IP.
     - Static IP hasn't been set. Use the spacebar when the "Select any Key to Configure IP Settings" is displayed and set the client IP address.

3) **Cannot Load Firmware**
   - **A) Is Thin Client connecting to ThinManager Server?**
     - **i) Using DHCP**
       - Has Option 066 been set to the ThinManager Server IP Address?
       - Is there a link light on the network port?
       - Check router address, IP Addresses, and Subnet Mask
     - **ii) Using Static IP**
       - Has the ThinManager Server IP Address been entered in the IP Configuration Menu?
       - Check router address, IP Addresses, and Subnet Mask
B) Is the network blocked?

ThinManager Ready thin client that communicate through routers, gateways, or firewalls may need some ports opened to allow data flow through these devices. If the thin client communicates through one of these and it is having trouble, check to see if these ports are allowed.

The required ports are:
- UDP/4900 - TFTP - Used for the TFTP download of the firmware.
- TCP/2031 - Configuration - Used to pass the configuration from the ThinManager Server to the thin client.
- TCP/1494 - Citrix - Used by the ICA protocol (if using ICA instead of RDP).
- TCP/3389 - RDP - Used by the RDP protocol (if using RDP in v2.4.1 or later).
- TCP/1758 – Multicast – Used for multicast download of firmware unless this feature is turned off in the ThinManager Server Configuration wizard.
- IGMP – Used with Multicast
- TCP/5900 - Shadowing - Used to shadow terminals. This port can be changed on the Shadow Configuration page of the ThinManager Server Configuration Wizard.
- ICMP Echo Packets (Ping) – Used by Enforce Primary and WinTMC.
- DHCP - This needs configured as needed.

C) Loads firmware intermittently/slowly

- Check for IP conflicts
- Check cable connections
- Make sure ThinManager Server CPU usage is below 100%

4) Thin Client Loads Firmware but fails to load configuration

A) "Please Define on Server"
- Enter ThinManager and define the terminal.

B) "License Not Available"
- Check your license usage in ThinManager. You are out of an ACP-supplied License.
- The Installation ID may come from the motherboard serial number, the MAC address on the network cards, or the GUID from the operation system. Don't change or disable the network cards after licensing to prevent changing the Installation ID, which can affect the validity of the license.

C) "This Terminal Disabled"
- A ThinManager administrator has disabled this terminal. Re-enable it.

D) "Network Error - Check Network Connections"
- Check the network cable, link light, and network.

E) Was Disabled, but did not go on when re-enabled.
- Reboot.
F) Is WinTMC Loaded on ThinManager Server?
- Make sure that the WinTMC client is not installed on the ThinManager Server. The WinTMC client will try to open the 2031 port that ThinManager needs to communicate with thin clients, causing a port conflict. WinTMC is for PCs, not servers. Uninstall the WinTMC client if it is present.

G) Terminal Selection menu is shown, but keyboard does not work
- Check keyboard and reboot
- Use PS/2 splitter if the unit has only one PS/2 port
- Switch the mouse and the keyboard if plugged into a PS/2 splitter.

5) Graphical ACP Logo is shown, but boot process stops
A) Does not attempt to connect to the terminal server
- Check Terminal Configuration Wizard to make sure a terminal server is specified

B) Cannot Connect to Server xxx (0.0.0.0)
- The terminal server doesn't have an IP address configured in the Terminal Server Configuration Wizard.
- If using DNS, check the terminal server's registration.
- If you are using a Citrix Published Application, you may need to specify the ICA browser.

C) Cannot Connect to Server xxx (w.x.y.z)
- Check the event viewer on the terminal server. If it says "Could not issue client license", you need a Microsoft Terminal Server Client Access License (MS TS CAL) and/or a Microsoft Terminal Server Licensing server.
- Check the Subnet Mask in the ACP Boot Loader on the thin client. If it is set to 255.255.255.255 instead of 255.255.255.0, it will fail to connect to the terminal server.
  Reboot the thin client and use the spacebar when the "Select any Key to Configure IP Settings" is displayed. Change the subnet mask in the ACP Boot Loader menu.

D) Error 50 - Disconnected
- Check the event viewer on the terminal server. If it says "Could not issue client license", you need a MS TS Cal / MS TS Licensing server.

6) Attempts to connect to terminal server, but dies
- Some servers (Dell and its Dellwall.bmp, for example) load a complex bitmapped background that can interfere with loading. Find the offending wallpaper file on the console session and rename it so that it doesn't load at login.
7) Connects to connect to terminal server, but cannot login
   - Is the user a valid user? Is the password correct?
   - Does the user have permission to connect through Terminal Services (user properties in the User Manager)
   - If logging in to a Windows 2003 or 2008 terminal server, is the user a member of the Administrators group or Remote Desktop Users group?
   - Check the event viewer. If it says "Could not issue client license", you need a Microsoft TS Cal and or a Microsoft TS Licensing server.
   - When terminal server is in 2 domains and an administrator logs into the console with a domain account it sets that as the default domain. If the terminals are configured to use the other domain they will be unable to login. Login to the console with the domain of the terminals to reset the default domain.

8) Login to Terminal Server prompts for password even though the username and password are filled in ThinManager
   - The password may be entered wrong in ThinManager.
   - Windows 2000 Server is set to always prompt for password at login for RDP users. Select Programs>Administrative Tools>Terminal Services Configuration and double click on RDP-tcp Properties in the right-hand window. Uncheck the Always Prompt for Password checkbox on the Login Settings tab.

16.2. Thin Client is Running a Session on the Terminal Server

9) Disconnects randomly
   - Make sure each user is logging on with a unique user name. Windows 2003/2008 will only allow one session per name by default.
   - Check the physical network connection.
   - Check for a different computer (e.g. a laptop) with the same IP address.
   - Slow down the Monitoring Interval on the Monitoring Connection page of the Terminal Configuration Wizard by increasing the timeout and retry values.

10) The session in Windows 2003 requires frequent logins
    - Turn off the Windows screen saver. User accounts in Windows 2003 use a secure screen saver by default that requires this frequent login.

11) Mouse works but the application is unresponsive
    - Application on terminal server is locked up - kill the application and let the thin client reconnect to terminal server and restart the application

12) Sound doesn’t work
    - Make sure that you are using a Windows 2003 or 2008 terminal server
    - Make sure that Audio Mapping is allowed on the Client Settings of the RDP-tcp Properties in the Terminal Server Configuration Console.
    - Make sure that you are using a ThinManager Ready thin client that has sound capability
    - Use the Sound Module for that specific thin client
    - Connect a powered speaker to the "Line Out" plug. Line Out isn't amplified so it requires a powered speaker.
• Properly working sound will play a sound at boot and at login.

13) The touch screen doesn't work
• Make sure you are using the right Touch Screen Module for the touch screen controller.
• Make sure that the serial cable is plugged into the correct serial port
• Make sure that the Touch Screen Module is using the correct baud rate.
• Use the USB Touch Screen Module if the touch screen is USB, or set the Connection Type to USB on the regular touch screen module.

14) The touch screen mouse doesn't match the touches.
• Calibrate the touch screen by highlighting the unit in the ThinManager tree and select Tools > Calibrate Touch Screen.

15) Changes to the configuration in ThinManager don’t show up on the thin client.
• Restart or Reboot the thin client. Changes are only sent to a thin client at bootup.

16) The configuration of the primary ThinManager Server and the secondary ThinManager Server are different.
• Enable automatic synchronization by selecting Manage > ThinManager Server List or manually synchronize the configurations by selecting ThinManagerServer >Synchronize in the ThinManager menu bar.

17) The terminals in the tree on the primary ThinManager Server show green while the terminals on the secondary are all red.
• Enable automatic synchronization by selecting Manage > ThinManager Server List or add both ThinManager Servers to the ThinManager Server Monitor List in the Terminal Configuration Wizard. Reboot the terminals and synchronize the ThinManagers as in Number 16.

18) The client is showing the time of the terminal server in a different time zone and not the local time.
• Use the Time Zone Redirection Module on the client with the local time zone selected.
• Make sure that the security policy of the terminal server or domain allows it. Look at Computer Configuration > Administrative Templates > Windows Components > Terminal Services >Client/Server data redirection >Allow Time Zone Redirection and set it to Enabled.

19) When "Terminal Servers" is highlighted in the ThinManager tree, the Details pane doesn’t show OK for the connections.
   A) “No login information supplied”
   • Run the Terminal Server List Wizard and add an administrative user name and password on the Terminal Server Name page of the Terminal Server List Wizard.
   B) “User specified does not have permission to connect”
   • This indicates that the Terminal Server had an invalid username and password added on the Terminal Server Name page of the Terminal Server List Wizard. Run the Terminal Server List Wizard and change to an administrative user name and password on the Terminal Server Name page of the Terminal Server List Wizard.
- Use the domain in the Domain field on the Terminal Server Name page of the Terminal Server List Wizard.
- If not in a domain, try using the terminal server name in the Domain field on the Terminal Server Name page of the Terminal Server List Wizard.

**C) WTSAPI32.dll connection failed**
- This occurs when the terminal server is off or unreachable. Try pinging the terminal server.

**20) The Users, Sessions, and Processes tabs don’t show data for a terminal server**

**A) No login information supplied**
- Run the Terminal Server List Wizard and add an administrative user name and password on the Terminal Server Name page of the Terminal Server List Wizard.

**B) User specified does not have permission to connect**
- This indicates that the Terminal Server had an invalid username and password added on the Terminal Server Name page of the Terminal Server List Wizard. Run the Terminal Server List Wizard and change to an administrative user name and password on the Terminal Server Name page of the Terminal Server List Wizard.
- Use the domain in the Domain field on the Terminal Server Name page of the Terminal Server List Wizard.
- If not in a domain, try using the terminal server name in the Domain field on the Terminal Server Name page of the Terminal Server List Wizard.

**21) The Users and Sessions tabs show data for a terminal server, but the Processes tabs shows no data.**
- Shorten the name of the terminal.
  Microsoft truncates the terminal names to 15 characters. The Process information won’t display for terminals with a name longer than 15 characters.

**22) When shadowing a client the mouse doesn’t work in the shadowed session.**
- The user must be logged into the shadowing computer as an administrator, or as a ThinManager Administrator, or member of a security group that is given permission to use interactive shadowing in the ThinManager Server Configuration Wizard.
- The interactive shadow must be checked in **RemoteView** on the ThinManager menu.
- A terminal using the Share Keyboard and Mouse module will only be interactive if the mouse is active in that session.